SIte Update

By November 29, 2010Site-news

Despite the best efforts of some talented people, we are not going to be able to recover the 8 months lost between our last site backup and the hack of the site.

In time we’re going to do our best to get some of the updates back via google cache, but the priority is to get the server set up properly and to get the main sections like the calendar, forum and image gallery back on their feet.

As we look forward, we’re considering hosting the server ourselves. It would mean saving money in the long run and we feel our hosts haven’t really had our back during this difficult period.

What we need to know is, has the site been significantly slower since it came back online? I ask this mainly of our North American visitors, as the site is currently being hosted in Sweden.


Author Dazza

More posts by Dazza

Join the discussion 12 Comments

  • nextyearsgirl says:

    I’m in North America, the site hasn’t seemed slower at all, though I’ve mostly been visiting the main page and watching any video clips because the galleries are still getting up and running. What I have seen of the galleries, they’re working as per usual.

  • thelucki says:

    I haven’t seen any change in the speed. So keep up going. You do a great job and I have no doubt that the site will look as great as before the %%%* when you have finished.

  • fechin says:

    I’m in North America as well and can agree with what nextyearsgirl said.

  • spoonbat says:

    Dazza – is it that we can’t afford to upload the last several months or is it more the server is that shot to hell?

    Also, here’s a rather salacious story:

    Salt shaker…..

  • revrezner says:

    Florida, USA. The site is considerably slower then before. Especially the gallery pages. The main page is sluggish as well.

  • dazza says:

    The files cannot be recovered.

  • omgzrachel says:

    Sorry to hear that, Daz. 🙁 The site slowed down a bit for me yesterday morning, but it was fine later on in the day. I haven’t experienced any other slowness since the site came back up.

  • #1NatPortfan says:

    Here in Puerto Rico sometimes it’s slow,but most it is fine.Dazza,what about the video section,is it lost forever,or there is a chance that some if not all can be recovered?

  • dazza says:

    The video section will be fine. The only reason its not working now is I hadn’t noticed it wasn’t working. There are lots of little errors because the site is on a different OS now, but Kris can fix them quite easily once they’re identified.

    However, any vids added in the past 8 months will need to be uploaded again.

  • CC: says:

    No speed problems here in central Canada. Keep up the good work.

  • Jenski says:

    Texas here. The main page has loaded slower than I recall it loading before but it’s only been once or twice. To be fair, I don’t check the site like 5 times a day like I used to.

  • PatrynXX says:

    RSS isn’t updating at all. It works. but last update was on the 28th. and looks like there’s been more.

    and for those who wanna feel better, childhood friend of my dads got a new computer, set it up when looking for his old one. Ahem his wife gave his old one to the relatives who promptly erased the entire drive. do’h. beyond. worse than not having a backup. Simply stupid. and I’ve known them my 35 yrs of life. X_X Just can’t figure what the logic was behind in that decision…